Incident Update: GCP Outage Impact – June 12, 2025
Resolved
Jun 12 at 02:55pm CDT
While our initial analysis confirms that there was no impact to Socure’s primary integration APIs or platform functionality, our team is continuing to monitor and evaluate the situation to ensure no downstream effects. We will keep you informed of any significant updates.
Affected services
Effectiv Workbench Application
Effectiv API Services
Created
Jun 12 at 01:00pm CDT
Dear Customers,
We want to inform you that earlier today, June 12, 2025, Google Cloud Platform (GCP) experienced a service outage that may have led to intermittent connectivity issues across various services.
While our initial analysis confirms that there was no impact to Socure’s primary integration APIs or platform functionality, our team is continuing to monitor and evaluate the situation to ensure no downstream effects. We will keep you informed of any significant updates.
Due to the broader GCP outage, there was degraded performance observed in some of our subprocessors and dependent services:
• Google Cloud Platform – GCP Incident Details
https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
We are committed to maintaining transparency and ensuring the reliability of our services. Our teams will continue to monitor all systems closely and provide updates as needed.
If you have any questions or notice anything unusual, please don’t hesitate to reach out to our support team.
Thank you for your continued trust in Socure.
Best regards,
Socure Support Team
Affected services
Effectiv Workbench Application
Effectiv API Services