Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 26, 2025 - 06:00 UTC
Scheduled
On Sunday, October 26, between 6:00 AM and 7:00 AM UTC our authentication service provider will be performing a scheduled database maintenance.
No downtime is expected during this window, though you may notice slightly elevated latency for a few seconds on certain operations while we complete the maintenance. All signed-in users will remain unaffected, and no disruption to active sessions is expected.
This activity will not have any impact on the Effectiv API Services.
Thank you for your understanding, and we're happy to answer any other questions you have about this!
Posted Oct 17, 2025 - 09:14 UTC
This scheduled maintenance affected: Effectiv Workbench Application.