Degraded availability/ partial impact for data providers using AWS services

Incident Report for Effectiv

Resolved

We’re pleased to share that all Socure services have now fully recovered and are operating normally. We are currently serving 100% of traffic without any issues, and all system latencies and performance metrics have returned to expected levels.

Our engineering and operations teams will continue to work closely with AWS to conduct a comprehensive root cause analysis (RCA) of the incident. We will share the RCA publicly within the next few days once this review is complete.

We appreciate your patience and understanding throughout this event and thank you for your continued trust in Socure.
Posted Oct 20, 2025 - 23:21 UTC

Update

Our systems are now close to full operational capacity. All core services are functioning as expected, and we continue to closely monitor performance to ensure full stability.
Posted Oct 20, 2025 - 17:50 UTC

Monitoring

Service performance is gradually improving as AWS works to resolve their ongoing incident. While the issue remains partially unresolved, we’re seeing signs of recovery. We’ll provide another update once there’s a significant change in status.
Posted Oct 20, 2025 - 13:39 UTC

Update

We are currently experiencing an incident due to an ongoing AWS infrastructure issue impacting one or more of our data providers. As a result.
Authentication providers are also affected leading to Login failures

We will continue to post updates here as more information becomes available.
Posted Oct 20, 2025 - 09:29 UTC

Identified

We are currently experiencing incident due to an ongoing AWS infrastructure issue affecting one or more data providers.

We will continue to post updates here as more information becomes available.
Posted Oct 20, 2025 - 09:23 UTC
This incident affected: Effectiv Workbench Application and Effectiv API Services.