Our authenticator providers have resolved the issue at 03:55 AM EST and are actively monitoring to ensure that things remain stable.
Posted Sep 16, 2025 - 09:14 UTC
Investigating
Our third-party authentication provider is experiencing performance degradation. Some users may see intermittent login and access issues in the web application. Evaluation APIs are not affected. We're working with the vendor to restore normal performance.
Posted Sep 16, 2025 - 07:59 UTC
This incident affected: Effectiv Workbench Application.